Howdy! This document will go over why PHP versions matter for your WooCommerce store, how to upgrade PHP versions, and includes some sample emails you can send to your host to get upgraded.

Please note that all SkyVerge extensions for WooCommerce have required PHP 5.6 or newer as of March 2019. This means that you will not be able to update any extensions that require PHP 5.6 without first upgrading your server’s PHP version.

WordPress core also requires PHP 5.6! (details here)

What is PHP?

PHP is the programming language upon which WordPress, WooCommerce, and WooCommerce extensions are built. Just as WordPress or WooCommerce have version numbers to indicate updates, PHP also has version numbers to indicate updates to the programming language itself that make improvements to security, processing speed, or features that help developers build better software.

Just like it’s important to keep WordPress and plugins up-to-date, it’s important to use updated versions of PHP for best security and performance.

Why Upgrade PHP?

If you’re reading this, you likely saw a notice in a WooCommerce extension that prompted you to upgrade your server’s PHP version. While this may not be something you can do yourself, it is important to know what PHP is and what your host should be doing to ensure your site is speedy and secure.

WordPress currently supports PHP versions 5.6+, but recommends PHP7 or newer. While older PHP versions are still supported, these are not versions of PHP any modern site should be using, especially not an eCommerce site. Any PHP version less than 7.2 has reached “end of life”. This means the version no longer receives security updates or fixes, which can leave your site vulnerable.

Less than 10% of sites using our plugins are still stuck on outdated, deprecated version of PHP, and these should be updated.

Upgrading your site to a supported version of PHP, such as PHP 7.4, should pose no issues — plugins designed for PHP version as low as 5.6 will run in PHP 7.4 without any changes required 99.99% of the time.

While PHP 5.6 is sufficient, we highly recommend upgrading to PHP7 or newer if possible. This version of PHP provides dramatic performance improvements, almost 50% faster in some cases. Increasing site speed also helps your bottom line:

A 1 second delay in page response can result in a 7% reduction in conversions.

If you’d like to upgrade to PHP7, please ensure your site is compatible.

Checking for PHP7 Compatibility

If you’d like to ensure your site is PHP7 compatible, there are several compatibility checkers you can use to scan your site for incompatibilities. However, there are a couple important things to note about compatibility checkers:

  • While they detect most issues, they’re not 100% reliable. In our experience, they do enough checks to warrant moving to PHP7 if the checks pass, as they catch most serious issues.
  • Sometimes there are false positives, as this doesn’t know whether code has a PHP version check, nor does it check if any problematic code actually runs. For example, one of the payment gateways we build has a library bundled with it that flags a PHP7 notice. However, this code never runs, and all of our plugins are PHP7 compatible. If a plugin is flagged, double-check with the author of that plugin.

If you’d like to prepare your site for PHP7, we recommend taking a couple steps:

  • Use the PHP compatibility checker plugin to scan your site for known issues. If you use SiteGround, you can use the SG Optimizer plugin instead.
  • Reach out to developers of plugins on your site to confirm PHP7+ compatibility.
  • If your host has the ability to provide a staging site on PHP7, ensure tests are done on this staging site. Otherwise, be sure of an immediate backup before upgrading to PHP7 in case a roll-back is needed.
  • Request an upgrade for your live site! If you use SiteGround, you can even flip the switch yourself.

Email Your Host

If your host doesn’t provide a way for you to upgrade yourself to PHP7, then you can email to request an update. The Yoast Team also has a very good collection of popular hosts and their instructions to upgrade PHP. If your host is not listed, consider sending the following (you could also request PHP 5.6 if you don’t think your site is ready for PHP7):

Hey there,

I'd like to update the PHP version of my WordPress site to PHP7 for improved security and increased speed. WordPress also strongly recommends at least PHP7 on their requirements page here:, and PHP has information about supported versions of PHP here:

I understand that sometimes a website can break when updating the PHP version, so could you assist me to update my site safely to use PHP 7?


This is the exact kind of request any hosting company should be able to fulfill. If your hosting company will not update your site’s PHP version, then you could consider moving to a modern managed WordPress host.

If your host will not upgrade PHP for your site, then we recommend checking out another host. Here are some of our preferred hosts, each of which supports essential eCommerce features.

*WP Engine provides some default caching configuration for WooCommerce, but it is incomplete. If you opt to use them, you will need to request additional caching exclusions, such as excluding WooCommerce API endpoints, query parameters, and session cookies. Without these, WPE can be problematic with extensions.

**We also sometimes see issues with SSL certificates / redirection on WP Engine. For best performance, be sure to ask them to force the entire site over SSL — this gives you an SEO boost anyway, so it’s recommended 🙂

SkyVerge Plugin Updates

So what will happen when this deadline hits? Will your plugin break? No, not immediately.

Here’s what will happen:

  • When we require new versions of PHP, we add a note to the changelog to publicize this new requirement.
  • While not every plugin will be updated immediately, any minor release can require a new PHP version. (You can tell a minor release if the “X” number is incremented in the version: version y.X.y or the first number: X.y.y)
  • If your site does not use PHP 5.6 or newer, you should not update extensions, as they will become non-functional. While they won’t create any errors in PHP 5.6, they will not execute any of their code. This can have serious effects if, for example, your payment gateway needs you to update PHP before it will function again. Please mind the changelog for the plugin updates around this time.
  • While this may not affect your site immediately, this means that you will no longer be able to receive fixes, security updates, or WooCommerce updates, so updating PHP is a requirement for the future.